Access to User Management API with Google Apps Script

I’ve been turning myself inside out trying to access the User Management API for Jira Cloud.

I’m using Google Apps Script, following instructions from here, following the instructions posted in Atlassian documentation.
(I can’t post the link due to limitations here)

I have both org and site admin permissions. I am using an API Token that I generated from here. “Manage an organization with the admin APIs | Atlassian Support

I run many scripts on the regular public rest API with no problem.

I get 403 messages with this error “OAuth 2.0 is not enabled for method: GET”

Note that because I’m desperate, I have tried with both just the API token (no org ID), and with the org ID (with the org ID, I get a 404)

I have also tried Basic auth, but as we all know, that’s been deprecated.

Here’s my code:

function getMgmtPermTest(){

var url = “https://api.atlassian.net/users/xxx.../manage”;
var orgId = “123…”
var apiToken = “123…”

var encCred = Utilities.base64Encode(orgId +":"+ apiToken);

var params = {
method:“GET”,
contentType:‘application/json’,
headers:{Authorization:"Bearer "+ apiToken}, // 403 - have also tried putting "Authorization in quotes
//headers:{Authorization:"Bearer "+ encCred}, // 404
};

var response = UrlFetchApp.fetch(url, params);
Logger.log(response.getResponseCode());

}

Thanks in advance for any help!