Add-on failed to install - how to get more information

Hi, I tried to create a simple add-on that uses some webhooks as described here:
https://developer.atlassian.com/cloud/confluence/modules/webhook/

I tried to install it my cloud developer instance but the only message I get is:
“The add-on failed to install. Please try again later or contact the add-on vendor.”

The result is the same when I use the marketplace or the direct link.
Is there a way to get more detailed Information on why this fails?

When I set the authentication type to none and delete the lifecycle key in the atlassian-connect.json the add-on installs successfully but does not send any hook data. Using jwt and lifecycle installed the respective installed url never gets called and the installation fails with the above message.
I use Let’s Encrypt as CA is that even accepted?

Check your server logs (if you’re using ngrok - check ngrok as well).

More than likely the error is due to the atlassian-connect.json being invalid (run it through a json lint checker or post it in here) or that the /install hook isn’t being called properly.

The only log, that I can find in the cloud instance, is called Audit log. Which is not very helpful because it only states: “Failed to install add-on”
I have no access (or can’t find it) to a more detailed log4j log as it is described here: https://confluence.atlassian.com/doc/working-with-confluence-logs-108364721.html

I used the Atlassian Connect Validator. My atlassian-connect.json is this:

{
     "name": "my name",
     "description": "my description",
     "key": "de.mykey.x.y",
     "baseUrl": "https://mydomain.io",
     "vendor": {
         "name": "my company",
         "url": "https://myCompany.de/"
     },
     "authentication": {
         "type": "jwt"
     },
     "lifecycle": {
        "installed": "/installed",
        "uninstalled": "/uninstalled"
     },
     "apiVersion": 1,
     "modules": {
        "webhooks": [
      { "event": "page_created", "url": "/page_created"},
      { "event": "page_removed", "url": "/page_removed"},
      { "event": "page_restored", "url": "/page_restored"},
      { "event": "page_trashed", "url": "/page_trashed"},
      { "event": "page_updated", "url": "/page_updated"}
    ]
     },
    "scopes": [
        "read"
    ]
 }

But the baseurl/installed url never gets called.

Are you able to access the descriptor through the https://mydomain.io location?

You should at least be seeing the descriptor being retrieved by JIRA.

Yes I can access the descriptor through a GET request or through the browser. I also can see that Confluence is making a GET request to the descriptor URL but not to any of the others. While installing I see half the progress bar load until it stops with the message The add-on failed to install. Please try again later or contact the add-on vendor.

OK I found the problem. The atlassian-connect.json needs to be published on port 443, explicitly stating another port will not work.