Adding wildcard as allowed origin doesn't work

Hello,
I’m trying to add wildcard ‘’ as allowed origin on the developer API-Key page
https://trello.com/app-key and I get the following message “The submitted URL is not valid”.
even though the page state the following: "Note that the wildcard '
’ will allow redirects to any origin."

Any suggestion ?

Thanks

We’re working on cleaning up the copy on that page because it is out of date. You can not add a wildcard as an allowed origin. However, some legacy API keys do have wildcards, so it is possible to see a wildcard in your allowed origins.

Thank you for the answer @bcook,

I’m developing an app for Android and iOS that authenticate Trello users and I would like to redirect the user back to my app after successful login. How can I do that?
When I enter my app redirect URL in the “New Allowed Origin” for example: myappname://authorize It changes the url to https://myappname after I click submit submit.

How can I add my app re-direct URL that is not start with https://?

Thank you

Check-out my answer here: Setting non standard allowed origin

I think that the workaround mentioned there is the same one you’d want to use.

Thank you for your help @bcook
Just implemented the suggested workaround and it works.

Is it possible to know if this use case will be supported in the future ?

Thanks

I don’t have a solid answer on that yet. Once I know more, I’ll add a reply.