ALERT: SSL cert is broken, causes maven build failures

Please fix your SSL certificate for atlas-run tries to connect to it and returns the following:

[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 7.895 s
[INFO] Finished at: 2017-05-31T13:23:18-07:00
[INFO] Final Memory: 48M/414M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.atlassian.maven.plugins:maven-amps-dispatcher-plugin:6.2.11:run (default-cli) on proj
ect searchandpackaging: Unable to execute mojo: Execution null of goal com.atlassian.maven.plugins:maven-confluence-plug
in:6.2.11:run failed: PKIX path building
 failed: unable to find valid certification path to requeste
d target -> [Help 1]

Browsing to that domain in Firefox results in a certificate unknown error (see screenshots) and Wireshark also shows an alert and error that is similar.

The only way I’ve found around this is to disconnect from the Internet before the atlas-run command. I better workaround would probably be to add an entry for that domain in your hosts file.


I’ve just tried to reproduce this and was unsuccessful. Is this still happening for you?


Perhaps you could update your local /etc/hosts file to point to somewhere where there’s no server that replies on port 443.

For example:

I tried the host workaround, I don’t think it matters. The problem is usually intermittent, which is strange. When I started this post, it had turned from intermittent to constant. Now it is intermittent again. Every morning, the first atlas-run fails and then every attempt after that works. It could be a bad/misleading error message.

1 Like

Yes, I also encounter this weird condition.
and the second atlas-run works. :joy: