AMPS 8.0.4 atlas-mvn install error

I’ve got an error on atlas-mvn install command after update from AMPS 6.3.12 to AMPS 8.0.4, Windows 10 , Powershell:

PS C:\Projects\UNIT6\JIRA\Pulse.Timesheet.Server> atlas-mvn install
"else" не является внутренней или внешней
командой, исполняемой программой или пакетным файлом.
Executing: "C:\Applications\apache-maven-3.6.0\bin\mvn.cmd" ${mavenPluginName}=$mavenPluginName -gs C:\Applications\Atlassian\atlassian-plugin-sdk-8.0.4\apache-maven-3.5.4/conf/settings.xml install
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for com.unit6.pulsekit:timesheet-server:atlassian-plugin:1.0.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-compiler-plugin is missing. @ line 311, column 21
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]
[INFO]
[INFO] ----------------< com.unit6.pulsekit:timesheet-server >-----------------
[INFO] Building timesheet-server 1.0.0-SNAPSHOT
[INFO] --------------------------[ atlassian-plugin ]--------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  1.741 s
[INFO] Finished at: 2019-02-13T18:44:42+05:00
[INFO] ------------------------------------------------------------------------
[ERROR] Unknown lifecycle phase "${mavenPluginName}=$mavenPluginName". You must specify a valid lifecycle phase or a goal in the format <plugin-prefix>:<goal> or <plugin-group-id>:<plugin-artifact-id>[:<plugin-version>]:<goal>. Available lifecycle phases are: validate, initialize, generate-sources, process-sources, generate-resources, process-resources, compile, process-classes, generate-test-sources, process-test-sources, generate-test-resources, process-test-resources, test-compile, process-test-classes, test, prepare-package, package, pre-integration-test, integration-test, post-integration-test, verify, install, deploy, pre-clean, clean, post-clean, pre-site, site, post-site, site-deploy. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/LifecyclePhaseNotFoundException

It looks like incorrect value of ‘MVN_COMMAND’ variable from atlas-mvn.bat script.

I’ve removed str 116

call set MVN_COMMAND=%%MVN_COMMAND:${mavenPluginName}=%MVN_PLUGIN%%%

To make it similar to atlas-mvn.bat from AMPS 6.3.12 and it works.

Also I can’t find information about ‘mavenPluginName’ variable in the documentation. So It looks like missed variable value.

Does Anybody know something about it? What should I set to avoid this message?

Linked issue: https://ecosystem.atlassian.net/browse/AMPS-1480

7 Likes

Thanks !! it worked .

Thanks for the post. It helped a lot. :+1:

Thank you. I got same issue with Atlassian SDK 8.0.7. Worked after implementing your fix.