API for user search no longer accepts wildcard

I have been successfully using the following API call for a few months now to get all Jira users


Suddenly, I get an empty response with this call - it seems as if you have to specify the username. I’ve looked at the documentation, which doesn’t mention the use of the wildcard “%”, but I know I read somewhere that it could be used and has worked for months.

Does anyone know what has changed? Is it likely that this will work again?


username parameter has been deprecated and does not work anymore with the latest GDPR changes.

See https://developer.atlassian.com/cloud/jira/platform/api-changes-for-user-privacy-announcement/

Hi @andreas.schmidt

Thanks for this info. I understand that username has been deprecated, but it still works. If I use this call

/rest/api/3/user/search?username=‘warren levy’

it will return my details. What isn’t working since I tried sometime last week is the wildcard of username=%, which seems a bit baffling to me.

What API call / parameters do I need to use to get the details of all users on my instance of Jira?


We were facing the same issue and after doing trial and error with different values we end up with /rest/api/3/user/search?query=

If you don’t supply anything in value of query, you’ll be able to retrieve all the users (1000 max per call) . This seems to be working for us so far. Also, the behavior of % is not consistent, we observed some of our old instances still return users when we supply % in query.

I didn’t find any document on this so far but query with no value did the trick for us.

1 Like

Thanks @aakash.thakare

That works for me as well :grinning:. Until they make a change and it stops

1 Like


So we have been using the JIRA python package, which provides for a function ‘search_users()’ inside a class JIRA. The first parameter of this function is ‘user’ which we used to pass as a null string ‘’, and this used to return all users. But since yesterday, it is throwing an error -

“text: The username or property query parameter must be provided”

and when I do pass a value for user, it throws another error=

“The query parameter ‘username’ is not supported in GDPR strict mode.”

I get it that they’ve disabled username in APIs due to GDPR, but I am unable to find the updated python package to support the same, as the current package (V 2.0.0) still uses the old way to get users.

Any help would be appreciated. Thanks!

1 Like