App installed by private listing demands payment

We develop apps and test them on several Cloud instances. We use private listings and access tokens, but it seems that it’s not working any more:

I’ve tried to create new tokens, reinstalled the app, but still the payment is upcoming, and I can’t see a way to fix it.

Has something changed recently about that? Please don’t send to ecosystem service desk, it’s simply impossible to explain to them in a reasonable time what the problem is about.

3 Likes

The problem is that your Marketplace trial is still active. You should

  • Remove the access token;
  • Stop trial;
  • Add back Access token and specify the desired license status.

Kind regards,
Raimonds

2 Likes

Oh, that worked. But not exactly the way you’ve described.

I had to:

  • remove the token
  • unsubscribe
  • uninstall
  • install again with the private link by uploading

I believe the problem is that Marketplace for some reason just clean up evaluation end date if the app is install via search. Could that be the reason?

@raimonds.simanovskis, same issue happened in the other instance. I’ve followed your instructions, and everything worked out just right. Thanks a lot!