Atlaskit docs/access/sandbox seems to be broken

Hey community,

I am used to access Atlaskit documentation and I tried to figure out the DynamicTable sorting usage, as the documentation doesn’t tell you how to use it easily, I had to take a look on the examples with source codes, I need to access details in the cells definitions in order to understand the sorting engine, however the sandbox is broken and it states the following error:

Is there any issue reported regarding it?

Also, I tried to access the repository to create an issue there, I don’t have permission to access in bitbucket to figure out my question about the sorting thing.

References:

Best regards,

Andrey Bidinotto

Hey mate thanks for posting.

For sorting it’s not the most visible but if you scroll to the bottom you can see this text https://atlaskit.atlassian.com/packages/core/dynamic-table:

Sorting
Make sure to define a unique key for every cell, you can see this at work in one of the table examples. The reason for this is they’re used to uniquely identify the elements so sorting can occur (and React can do its bit too)!

Unfortunately for code sandbox not working it’s probably because the repo was closed sourced so it can’t access the repo anymore to extract the files. Let me check what’s happening with the public mirror and perhaps we can get it working again.

Edit: The public mirror is available here: https://bitbucket.org/atlassian/design-system-mirror/src/master/

Cheers,
Michael

1 Like