@atlaskit/theme is broken

Cross posting from https://bitbucket.org/atlassian/atlaskit/issues/41/invalid-dependency-on-atlaskit-theme-100 to make this more visible to Atlassian

Hi @jbevan thanks for raising this here as well. The root issue should now be fixed, as the affected AtlasKit package versions (that had a dependency on a non-existent version of @atlaskit/theme) have been unpublished from npm. We’re following up with new releases to re-publish those versions with the correct dependency.


1 Like

Hi @bgummer, thanks for your quick response. @atlaskit/multi-select@6.9.2 still references @atlaskit/droplist@4.0.0, which still references @atlaskit/theme@1.0.0. This breaks our build. Please could you have a look at this. Thanks

Hi @ratwal multi-select’s depndency on droplist is ^4.0.0 (caret range, i.e. 4.x) which includes the latest droplist version (4.9.0) which has a dependency on @atlaskit/theme@2.0.0

If you’re still getting errors it could be because your local npm cache is serving the old package versions. Clearing your npm/yarn caches should help.