Atlassian-connect Dynamic Content Module - non-string parameters

Hi,

I am developing an atlassian-connect Dynamic Content Module macro for Confluence cloud. I want to be able to configure the parameters for the plugin, however the non-string type parameters do not seem to be set in the url.

For example in the atlassian-connect.json below “htmlAttachment”, “frameborder”, and “scrolling” parameters are not being injected into the “url” (“frameborder” and “scrolling” can be set through the config page for the macro). Also, the HTML attachment does not appear to pick-up the attachments on the page.

"modules": {

"dynamicContentMacros": [

{

"url": "/foo?page={content.id}&space={space.id}&htmlAttachment={htmlAttachment}&scrolling={scrolling}&frameborder={frameborder}&width={width}&height={height}",

"parameters": [

{

"identifier": "htmlAttachment",

"name": {

"value": "HTML Attachment"

},

"description": {

"value": "The HTML file to embed"

},

"type": "attachment",

"defaultValue" : "",

"required": false,

"multiple": false,

"hidden": false

},

{

"identifier": "width",

"name": {

"value": "Width"

},

"type": "string",

"required": false,

"multiple": false,

"hidden": false

},

{

"identifier": "height",

"name": {

"value": "Height"

},

"type": "string",

"required": false,

"multiple": false,

"hidden": false

},

{

"identifier": "scrolling",

"name": {

"value": "Scrollling"

},

"description": {

"value": "Choose if scrolling should be enabled"

},

"type": "ENUM",

"required": true,

"multiple": false,

"defaultValue": "no",

"values": [

"yes",

"no",

"auto"

],

"hidden": false

},

{

"identifier": "frameborder",

"name": {

"value": "Frameborder"

},

"description": {

"value": "Surround IFrame with a border"

},

"type": "boolean",

"required": true,

"multiple": false,

"hidden": false

}

],

...

}

Thanks and regards,
Andrew

The docs for Macro Input Parameter for identifier states:

A unique identifier for the parameter. It must only contain lowercase alphanumeric characters, dashes, underscores, dots and must not contain any spaces. This identifier will be used in the query parameters of the add-on URL.

htmlAttachment contains an uppercase character and thus I feel like that may be causing your issue.

@rwhitbeck - thanks for your response. Changing the identifier to “html” makes no difference. When configuring the macro, the attachment drop-down doesn’t get populated with the page attachments.

Also, when setting parameter types to anything other than “string” causes them to be omitted from the URL request parameters sent to the Spring Boot macro.

Thanks
Andrew