Atlassian emoji not working on chrome incognito mode for cloud app

We are using Atlassian emoji from @atlaskit/util-data-test in the editor-core.
We have implemented like this,

import React from 'react';
import { Editor } from '@atlaskit/editor-core';
import { emoji } from '@atlaskit/util-data-test';

const emojiProvider = emoji.storyData.getEmojiResource({
  uploadSupported: false,
});

const Entry = () => (
  <span>
    <Editor
      appearance="comment"
      allowLists
      emojiProvider={emojiProvider}
    />
  </span>
);
Entry.propTypes = {

};

Entry.defaultProps = {
  page: '',
};

export default Entry;

But the app is not loading with the below exception,

DOMException: Failed to read the 'localStorage' property from 'Window': Access is denied for this document.

If we do this setting then working fine.

But we don’t want to restrict our app to do this setting.

If we commented emojiProvider like this then working fine.

import React from 'react';
import { Editor } from '@atlaskit/editor-core';
// import { emoji } from '@atlaskit/util-data-test';

// const emojiProvider = emoji.storyData.getEmojiResource({
//   uploadSupported: false,
// });

const Entry = () => (
  <span>
    <Editor
      appearance="comment"
      allowLists
      // emojiProvider={emojiProvider}
    />
  </span>
);
Entry.propTypes = {

};

Entry.defaultProps = {
  page: '',
};

export default Entry;

Thanks in advance.

We are using this version “@atlaskit/util-data-test”: “^15.0.1”