AUI Inline Dialog 2 not showing / not resolved

In Confluence, on content page, the AUI Inline Dialog 2 shows properly, but on other pages (space admin, etc) they don’t show.

If I take the default example given in Inline dialogs - AUI Documentation :

<a data-aui-trigger aria-controls="more-details" href="#more-details">
    A hyperlink as a trigger
</a>
<button data-aui-trigger aria-controls="more-details">
    A button as a trigger
</button>
<aui-inline-dialog id="more-details" aria-label="Example dialog">
    <p>Lorem ipsum.</p>
</aui-inline-dialog>

If I paste this EXACT code from the example on a page or a blog, even using Chrome’s dev console, it works OK. The <aui-inline-dialog> item receives the attribute resolved, showing it was seen by AUI automatically.

If I paste this code on a Confluence space administration page (or a page of our app), it doesn’t work, doesn’t display the popup, no resolved attribute appears, as if the trigger of AUI didn’t execute.

I have already tested:

  • On Confluence 7.13 (AUI 9.2)
  • On Confluence 7.19 (AUI 9.2.2)
  • Adding the dependency com.atlassian.auiplugin:aui-inline-dialog2, even though the AUI Inline Dialog 2 is supposed to be already in core.

It turns out adding the dependency to com.atlassian.auiplugin:aui-inline-dialog2 in the .vm file using #requireResource() worked.

I was using WRM plugin for Webpack, and I might not have been using it properly for my dependencies. Adding the dependency this way worked better:

import 'wr-dependency!com.atlassian.auiplugin:aui-inline-dialog2';
1 Like