Automation Action - config form keeps spinning, no request is sent to the app's server, what am I doing wrong?

I am trying to create Automation Action using following module:

"automationActions": [
        "key": "apply-template-action",
        "name": {
          "value": "Apply template"
        "configForm": {
          "url": "/render/automation-action-edit?projectKey={project.key}"
        "webhook": {
          "url": "/apply-template"

However, I can’t make the form to appear:

Action is visible, but nothing happens after I select the option. Spinner keeps spining. I don’t receive any requests on the server side. However, I do see a strange error in the network tab:

How do I make it work?

Today I’ve checked sample app: jira-servicedesk-hipchat-action

It is not working either, so I am assuming the feature is broken.

Hi @maciej.dudziak ,

I’ve created a minimal example for this which seems to work. You can install it from and you can inspect the code at Glitch :・゚✧.


1 Like

Hi @dmorrow, I tried your example and it worked. Thank you :slight_smile:
The only thing that was different were additional query parameters in the form url, which I had to put to atlassian-connect even though I don’t use them. It worked, so I didn’t check which or all of them are required, but it seems they are required to make it work.
Thanks again for help:)