Can we create the Connect Jira App without using the credentials.json file

I was looking for a way to create and host the connect Jira app without providing the credentials in credentials.json using ACE.
I have created my app using the Atlassian connect express. I could not find any way to restrict verifying the credentials and directly registering the app to the mentioned site.
I want to create the app using the framework but at the same time I want to register the app on the Jira cloud by uploading the link.
Is there a way to achieve this?


If I remember correctly the missing credentials file will also result missing ngrok tunnel. So you need to start a ngrok tunnel yourself (to the port ACE is started with). Then try to access the ngrok url to see if the atlassian connect.json is beeing served.
You should be able to use this url in your instance.

Is there a reason why you don’t want to use the credentials.json? If you want to provide a Dev version of a plugin that can be used by more people, you should consider using a “production” version on a server instead. (do everything that you would do for a production version, but make it easy to build a new version)

You don’t need the credentials file. If you do without one, you must manually install the app in your instance by giving the public url to your atlassian-connect.json.


Since you’re using ACE, there’s a super-easy way to prevent it from auto-registering your app on startup. Simply set the AC_OPTS environment variable to ‘no-reg’, like this:


There’s actually a few things you can control with environment variables, you can find a list of them in the here: Bitbucket


Yeah I tried that by providing the ngrok-generated URL in atlassain-connect.json file. I run the ngrok command separately and got the url. But while installing it on jira it gives me the error of unable to install.

Is there a reason why you don’t want to use the credentials.json?

The reason is that if I want to upload the connect app and if the third party need to use it then every time the third party have to add their credentials and run the app. Instead, as we build the app without ACE framework and get the URL, using that URL we can upload it on any site and use it without providing the credential, I want to create the same way the app and just provide the link to upload and install the connect app directly on jira.

I tried setting the environment to no-reg, but it is not initializing the ngrok. When I run the command “npm start”, it is not moving ahead as shown in image.