Cannot build AUI refapp / flatapp

Hi there,
I would like to take a look at the AUI RESTful table, and the documentation directs me here so I can build the AUI refapp and try it there.

Unfortunately I am not able to build the app as described in the readme, ‘npm install’ fails with:

3477 silly install printInstalled
3478 verbose stack Error: connect ETIMEDOUT 10.124.137.118:443
3478 verbose stack     at Object.exports._errnoException (util.js:1026:11)
3478 verbose stack     at exports._exceptionWithHostPort (util.js:1049:20)
3478 verbose stack     at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1090:14)
3479 verbose cwd /home/me/sandbox/aui-refapp/aui-adg
3480 verbose Linux 4.4.0-34-generic
3481 verbose argv "/home/me/.nvm/versions/node/v7.0.0/bin/node" "/home/me/.nvm/versions/node/v7.0.0/bin/npm" "install"
3482 verbose node v7.0.0
3483 verbose npm  v4.5.0
3484 error code ETIMEDOUT
3485 error errno ETIMEDOUT
3486 error syscall connect
3487 error network connect ETIMEDOUT 10.124.137.118:443
3488 error network This is most likely not a problem with npm itself
3488 error network and is related to network connectivity.
3488 error network In most cases you are behind a proxy or have bad network settings.
3488 error network
3488 error network If you are behind a proxy, please make sure that the
3488 error network 'proxy' config is set properly.  See: 'npm help config'
3489 verbose exit [ 1, true ]

There are more timeouts throughout the log to 10.124.155.116:443 and 10.124.137.118:443, to which the url npm-private.atlassian.io is pointing. I do not believe that network settings are the cause, because I have tried ‘npm install’ from three different locations, including in a private appartment. I cannot ping either IP-adress successfully.

I have cleaned my npm cache, I have updated npm to the newest version and I have even run ‘npm config set strict-ssl false’, although it felt very wrong.

I am an npm/node newb, so don’t rule out really stupid mistakes on my part :slight_smile:

Thanks for reading!
Claudio

Well 10. address are private ip’s (designed to be used behind a nat device). And since they’re pointing to npm-private.atlassian.io - I would say that you’d need to be on the Atlassian network in order to build this.

Not sure what you’re trying to do, but the source of restful table is here: https://bitbucket.org/atlassian/aui/src and you can download a prebuilt version of aui from: https://bitbucket.org/atlassian/aui-dist/downloads/?tab=tags

Oh, that certainly explains it, thx :slight_smile:

I just want to see what a RESTful table looks like and what it can do, whithout having to build one myself - like I can for (probably) any other AUI element.

I tried to build the refapp, because that is what the documentation tells me to do if I want to see a working example. However it does not tell me how to do that and the best that google could give me is this issue.
The accepted answer suggests to visit the repo which I mentioned in my previous post.

So, as I see it, the question becomes: Is there another way to build the refapp and if yes: which one? If no, I suppose I should raise a request to have the documentation updated.

If you’ve got JIRA, take a look at the versions of any project - that’s the restful table component :slight_smile: If you’ve got the atlassian sdk you can just do an atlas-run-standalone --product refapp and that should bring the refapp up for you.

Thanks again, Daniel! I’ll have a look at those versions!

As far as the refapp goes: I believe this ‘AUI refapp’ is different from the one that ‘atlas-run-standalone --product refapp’ brings up. So I’d still be interested in how to get the former up and running for future use and to see whether I should raise a request to have the docs fixed. That’s partly the point for my asking - I could have easily implemented a restful table myself with the time I have sunk into getting that darn AUI refapp going :slight_smile: So if anyone knows, please share!