Cannot migrate Server --> Cloud NullPointerException in com.atlassian.migration.agent.export.SpaceNoAttachmentsXmlExporter

I am using the “Atlassian Cloud Migration Assistant” in Confluence 7.14.0 to migrate a very simple space from Server to Cloud.

I just want to see inline comments in content get successfully migrated. The comments are on text that is in the body of a P2 macro on Server that will be a Connect macro on Cloud after the migration.

The migration keeps failing and I see a NPE in the atlassian-confluence.log. It appears to be happening during the migration at “stepType: CONFLUENCE_EXPORT”:

 -- stepConfig: {"spaceKey":"TMS","fileId":"d8458755-4043-4426-a6e6-3fe0d34a9200","cloudId":"***erasedByMe***"} | cloudId: ***erasedByMe*** | planName: Ture Test migration of inline comments - 3rd attempt | stepType: CONFLUENCE_EXPORT | stepId: 178d2340-db82-4e63-8f21-8c1d1443804b | planId: 4a5f1b2b-2ee3-410a-bec6-dc743b8357ca | cloudUrl: https://***erasedByMe*** | taskName: Migrate space TMS | taskId: 8b93d8e9-5917-48f1-b013-221b714b3262
java.lang.NullPointerException
	at com.atlassian.migration.agent.export.SpaceNoAttachmentsXmlExporter.configureXmlExporter(SpaceNoAttachmentsXmlExporter.java:83)
	at com.atlassian.migration.agent.export.SpaceNoAttachmentsXmlExporter.doExportImpl(SpaceNoAttachmentsXmlExporter.java:76)
	at com.atlassian.migration.agent.export.SpaceNoAttachmentsXmlExporter.lambda$doExport$1(SpaceNoAttachmentsXmlExporter.java:71)
	at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:829)

For this failed 3rd attempt I had added an attachment to a page in the space in hopes that having at least one attachment in my space would help w/ the NPE in the “SpaceNoAttachmentsXmlExporter.java”.

NPEs are normally the easiest Java bug in the world to fix so I’m hoping this is something that can be addressed without more information but I’m happy to provide more if needed. My space is simple. 2 pages, a few macros on the pages, really not much going on.

Thanks.

1 Like

My current migration tests are failing exactly with the same error message. I’m also on 7.14.0 with the latest version of the Migration App.

1 Like

Hello @andreas1
I have a DEVHELP ticket opened with Atlassian. No response from them yet. I pointed them to this thread so maybe they can update this thread when they address the issue.

1 Like

FYI, the problem has been reproduced and a bug has been filed. https://jira.atlassian.com/browse/MIG-883.

As soon as there’s more information, information will be shared on that ticket.

1 Like