Cascading select fields randomly not available

Hi,

One of our cloud customers ran into “glitchy” problem with cascading select fields in their sandbox environment. They configured a customfield of cascading select type (parent / child) where the parent has 10s of options and the child has 15-20 options.

When using the field, the child options disappeared at on random occasions. Reloading the page displaying the issue got the parent/child values to appear again.

They reported it to Atlassian but no conclusion on why this problem occurred was found.

They have now moved on from the sandbox environment and onto production use of Jira Cloud.

Now, they are using our app to display these fields and are seeing similar problems. We just tried to troubleshoot it and got to see a similar glitchy behavior, in that sometimes everything loaded as expected but sometimes the field values were not found at all.

Using the /rest/api/3/field endpoint we tried listing the fields configurations. In doing so, we noticed that Microsoft Edge never (or at least not while we were trying) displayed the customfields for the cascading select fields in question.

Switching to Google Chrome, the fields list was displayed including the cascading select fields.

Anyone out there who has ran into this type of “glitchy” behavior in Jira Cloud?
I.e. fields “sometimes not working”?

Any help/pointers here greatly appreciated!

Thanks,
Fredrik