Confluence does not recognize languages in atlassian-descriptor.json

I am tryign to add internationalization to my Confluence add-on and cannot add a number of languages that Confluence supports, but error during installation. The affected languages are:

dutch, swedish, finnish, norwegian, and japan

here is the descriptor definition:

"translations": {
    "paths": {
        "fr-FR": "/translations/fr_FR.json",
        "es-ES": "/translations/es-ES.json",
        "de-DE": "/translations/de-DE.json",
        "ko-KR": "/translations/ko-KR.json",
        "ru-RU": "/translations/ru-RU.json",
        "nl-NL": "/translations/nl-NL.json",
        "ja": "/translations/ja.json",
        "sv-SE": "/translations/sv-SE.json",
        "no": "/translations/nl-NL.json",
        "fi-FI": "/translations/fi-FI.json"
    }
}

What language codes do I need to specify to add these languages.

Didn’t know this existed!

Don’t know if that has anything to do with your problem, but the language code for Norwegian is almost certainly wrong (and it references the Dutch file).
There are two languages in Norway (actually versions of the same language):

  • Bokmal - code is nb or nb-NO
  • Nynorsk - code is nn-NO

I also think that the Japan code is wrong, shouldn’t it be ja-JP.
Maybe this helps

Thank you Christoffer. JA-JP works, but none of the norwegian options do.

Can you try nl_NL instead of nl-NL ?
And try no_NO for the Norwegian.

I’m basing myself on this page for these suggestions: https://translations.atlassian.com/ (Take a look at the download links for each language)

Just wondering if that might be the problem.

Still doesn’t work with the underscore. I submitted a ticket with developer support and will update here if I have an answer.