Convert content endpoint returns unknown attachments

Hello, guys
I’ve faced the following problem migrating from rest api v1 to v2.

In v1 we’ve been gathering all pages’ content from space in html format by simply using get content endpoint with ‘expand’: ‘body.view’.

Since this endpoint is deprecating and unavailable in v2 I’ve tried the following. Get pages with get pages for space endpoint and than convert the content with converter. For some reason all my attachments became unknown after conversion. The same happens with all available formats.

Can anybody help me with this issue, please? Or maybe it’s 100% that body content in html format will be available in v2 later?


1 Like

Dear Andrey,

unfortunately I have never tried in on my own but just to be sure: did you specify the spaceKeyContext in your call?

Best regards


Hello Andreas!

Yes, I’ve specified spaceKeyContext, this point fixed my urls in atlas_doc_format, but not in storage format. Unfortunately it doesn’t help with attachments.


Hi @AndreyDemidov - we will get the view format added. Thanks for the feedback here!

1 Like

Hi @SimonKliewer! Great news! Could you, please, share the task to track progress? Thanks in advance.

Hi @AndreyDemidov - here is a public ticket to track the progress!

1 Like