Custom UI (React) - External API(Hosted ec2) connection doesnt work

I have updated manifest

  external:
    fetch:
      backend:
        - '*.typicode.com'

I have also added certs in SSL folder which I am passing through my API. Its a get call.

export  default function apiCall(){
  var myHeaders = new Headers();
  myHeaders.append("Content-Type", "application/json");
  myHeaders.append("Authorization", "Basic xpto-asdasd");
    
  var certificado = JSON.stringify({
    "id": "xpto_id",
    "matches":{
    "pattern": "https://https://jsonplaceholder.typicode.com/*"
    },
     "pfx":{
    "src": "jsonplaceholder.typicode.com.cer"
    }

  });
  
  var requestOptions = {
    method: 'GET',
    headers: myHeaders,
    certificate: certificado,
    redirect: 'follow'
  };
  
  fetch("/todos/1", requestOptions)
    .then(response => response.text())
    .then(result => console.log(result))
    .catch(error => console.log('error', error));
  

Whenever I try to hit a call from custom UI to external API I am getting 403 forbidden . Is there something that I am missing ? Can someone help me look into this ?

Welcome to the Atlassian developer community @KetakiShintre,

On the Atlassian side, the Forge fetch basic documentation reads

options See the node-fetch library’s Options documentation for the accepted values.

So navigating to the linked page, I don’t see certificate as a valid option. Keep in mind that the current runtime (aka Runtime v1) is not really Node.js. Specifically, the fetch function is a custom implementation and is not something you can replace by adding a different npm library.