Deploy to development fails with unknown error

Hi there,

today, I got an error when trying to deploy a forge app to development. Running the command with --verbose gave me this additional information:

Found 1 function definitions
  Deploying "main" function
  Updated function "main" configuration
  Deployment failed with unknown error

Error: Deployment failed

Error: Deployment failed
    at ArtifactDeployer.handleErrorEvent (/usr/local/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:151:15)
    at ArtifactDeployer.pollAndCheckEvents (/usr/local/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:61:18)
    at processTicksAndRejections (node:internal/process/task_queues:94:5)
    at async ArtifactDeployer.monitorDeployment (/usr/local/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:72:28)
    at async ArtifactDeployer.deploy (/usr/local/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:36:9)
    at async PackageUploadDeployCommand.execute (/usr/local/lib/node_modules/@forge/cli/out/deploy/package-upload-deploy.js:14:9)
    at async CommandLineUI.displayProgress (/usr/local/lib/node_modules/@forge/cli/node_modules/@forge/cli-shared/out/ui/command-line-ui.js:44:28)
    at async DeployView.reportDeploymentProgress (/usr/local/lib/node_modules/@forge/cli/out/command-line/view/deploy-view.js:50:24)
    at async DeployController.run (/usr/local/lib/node_modules/@forge/cli/out/command-line/controller/deploy-controller.js:122:27)
    at async Command.actionProcessor (/usr/local/lib/node_modules/@forge/cli/out/command-line/command.js:76:32)

I recently updated to Forge CLI version 2.0.5. Don’t know if it has been working before after the update.
I tried it with two other apps as well, same error. So, it doesn’t seem to be an issue with the apps code or manifest. Also, didn’t have problems with deployment of my apps so far.
Does anyone have an idea what this might be and how to fix it?

Hey @ij-s. Yep, sometimes errors like this happen and we’re working on fixing this.
In the meantime, could you please deploy with --verbose flag and share the output?

Hey @ij-s,

We were experiencing issues on our side for app deployments for the past few hours (which is the likely cause of your issue)

More info here: https://developer.status.atlassian.com/

Thanks :slight_smile:

Hey @Dmitrii, @Aryan,
thanks for your quick responses. I have noticed the message on the status page now. As it said the issue is resolved, I tried it again and it worked now :+1: