Documentation issue in ACE

The https://bitbucket.org/atlassian/atlassian-connect-express/src/master/ README.md says about the config.json:

 //     "logging": function, //optional - function that gets executed every time Sequelize would log something.

Probably this documentation is not correct. It is possible to fill in the symbol false to disable sequelize logging. As it’s a JSON file, it’s impossible to fill in a function. And the string representation of a function does not work.

When looking at the source code for lib/store/sequelize.js, you can see that logging is set to logger.info for any trueish value.

It would be great if there was more documentation on logging in ACE.

Related PR: https://bitbucket.org/atlassian/atlassian-connect-express/pull-requests/126/allow-disabling-of-sequelize-log/diff

@acalantog Is there a better way to report this?

Hi @marc,

I’ve created a product issue on this, see https://ecosystem.atlassian.net/browse/ACEJS-148

Cheers,
Anne

1 Like

If I got this issue right, then now you can set the “logging” option to false in config.json. So It will provide ability to disable sequelize logging.

Hi piskunovigorm,

I saw this post,which was you already posted in aug’19. I am currently facing same issue. will you please help to resolve?

Hi
I’m using option_timetracking_changed webhook in order to keep web-panel updated according to time tracking changes. And it works perfectly for ‘Original Estimate’ field. Unfortunately it’s not working for ‘Time Tracking’ field.
image
Does it mean I should use different option for this field?

@piskunovigorm yes, you got this right, just set the logging option to false.

@SamProfit1 Your problem is quite different and not related to the problem in this thread.

yes @marc . but he already posted in this same problem, I need his help or reference . so, that is reason i mentioned here. If you have an idea about my problem, kindly give me suggestions