DropdownItem onClick is not working on ACE

I have created new project using Atlassian Connect Express(atlas-connect new <project_name>), but DropdownItem onClick is not working. I tried it in sandbox, it’s working as expected.

import React from 'react';
import DropdownMenuStateless, {
    DropdownItemGroup,
    DropdownItem
} from "@atlaskit/dropdown-menu";

export default function HelloWorld() {
    return <div style={{margin: "20px"}}>
        <DropdownMenuStateless
            trigger="Filter city"
            triggerType="button"
            appearance="default"
        >
            <DropdownItemGroup>
                <DropdownItem onClick={() => console.log("not working!")}>
                    Select All
                </DropdownItem>
            </DropdownItemGroup>
        </DropdownMenuStateless>
    </div>;
}

This problem is not related to Atlassian Connect Express (ACE), but it’s related to the React UI framework you’re using.

Please try reading the doc of Atlaskit:
https://atlassian.design/components/dropdown-menu/examples
https://atlassian.design/components/dropdown-menu/dropdown-menu-stateless/examples

Thank you for your reply, but i do not understand how this documents will help me. I started a new project with ACE from zero and dropdown items click event did not working. I did not make any configurations, i did what ACE documents say.

@ndao run into same problem, click event of dropdown menu is not fired! I did exactly what is told in documents. Can you please give further information about that?

@ndao I found out that Atlaskit components are not compatible with styled-components version 5.2.0 which is coming as default with ACE itself. This breaks a lot in components, for example onClick is not working. Atlaskit is compatible with v3.2.6, it says while npm install.
Newly created project with ACE has a builtin code in serverside-rendering.js, sheet.seal() method which is not present in styled-components v3.2.6, I comment out it and tried onClick, it worked!
This leads that project created by ACE is useless now? What do you recommend to do for users? Do you have plan to update Atlaskit or ACE? This is not stable to use in plugin development.
How come this relate to React UI itself?

An Atlassian Staff here refers that Atlaskit is not compatible other versions of styled-components.

Thank you for the report and investigation!

I’ve created a Jira issue to track and fix:
https://ecosystem.atlassian.net/browse/ACEJS-164

Hi thank you for creating the issue,
I cant see inside of this issue , I wonder the reply of it, thx

I cant see inside of this issue

Sorry, it was not public by default. I’ve set permission so that everyone can see.

@jhazelwood spent some time trying to fix, but unfortunately he couldn’t yet.