Environment confusion

I am getting this on the atlas-version:

When I should be getting something more like this:

ATLAS Version: 6.2.9 ATLAS Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9 ATLAS Scripts: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9\bin ATLAS
Maven Home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9\apache-maven-3.2.1 AMPS Version: 6.2.6

Executing: “C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9\apache-maven-3.2.1\bin\mvn.bat” --version -gs C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9\apache-maven-3.2.1/conf/settings.xml
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-15T04:37:52+10:00)
Maven home: C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.9\apache-maven-3.2.1\bin…
Java version: 1.8.0_91, vendor: Oracle Corporation Java home: C:\Program Files\Java\jdk1.8.0_91\jre
Default locale: en_AU, platform encoding: Cp1252
OS name: “windows 10”, version: “10.0”, arch: “amd64”, family: “dos”

Is it the version of the jdk I am using or how I have the path system variable configured wrong or what?
I’m kind of new to this, any help would be greatly appreciated.

Think I figured out part of the problem in it not finding java — needed the user variables changed too, the tutorial I was using assumed I had admin access so I was only editing the java_home environment variables.

as for the ignoring option maxpermsize I know I have to delete something bu I am not sure where

Hi, @Brian.Styer.

The MaxPermSize warning is displayed because this command line flag was removed in JDK 8 (please see Compatibility Guide for JDK 8). It should be fine if you leave it there, as I’ve been working with that warning and has not blocked me in any way. If by any chance you want to remove it, you can edit “C:\Applications\Atlassian\atlassian-plugin-sdk-6.2.8\bin\atlas-version.bat” and modify MAVEN_OPTS where it says “-XX:MaxPermSize=256M”.


Thanks @iragudo ! Good that it wont cause an issue but I attempted to remove it anyway. I removed XX:MaxPermSize=256M from all the .bat files in that bin folder but still get it. Maybe it is another place too?

Hi, @Brian.Styer. I tried it again on my Windows box (did the same on OSX) and was able to remove the message. I removed the following snippet in atlas-version.bat and the warning was gone.

Currently, there are only two possible scenarios I can think of for this not to work for you:

  1. The batch file edited is from a different SDK version you are currently referencing. Or,

  2. The “-XX:MaxPermSize=256M” argument is already set in %ATLAS_OPTS%. To verify that the argument is not there, in your command line kindly run echo %ATLAS_OPTS%, it should not return the MaxPermSize argument.

To minimize effort on your end, removing the argument in MAVEN_OPTS in one file, like atlas-version.bat, should be sufficient enough to remove the message when atlas-version is called.

Hope this helps!

Yeah, actually that did work for atlas-version. It still comes up with other commands like atlas-create-jira-plugin and such but I’m not too worried about it.

More importantly I can’t run the atlas-create-fecru-plugin, It says java8 does not support FeCru yet. Any way around that? I’ve looked for an older version of java and came up empty handed. Tells me I can use a more generic command like atlas-create-plugin but that would deviate from the wiki I was following that I had hoped would localhost a Crucible test environment for me.

Thank you for being so helpful. I can start a new thread for that last thing if you’d like.

1 Like

Yes, kindly start a new thread so that other members can also have a clearer context of the new challenge. Thank you.