Error while loading App

Hi there,

I am having problem to load app. Both in Dev and production environment.


Failed to run init function: TypeError: removeOldAnalytics is not a function

function() {
        setTimeout(bulkPublish, 500);

Any idea how to fix this?
Thank you

Hi Jan,

Based on the error message:

removeOldAnalytics is not a function

I would say that the call to removeOldAnalytics (the last line in the function) is failing because it either has not been defined in your source or has not been imported. Have you checked that the function exists / is imported and that there are no typos in your reference to it?


Hi @ddraper ,

the thing is I do not use removeOldAnalytics in my code anywhere.

Thanks for providing that clarifying. Could you provide some additional context on what you’re doing to see this error? For example what type of application you’re building? What extension point in which product, etc?

If you are able to describe the steps that you’ve followed, then that will help people reproduce the problem so that they will be better placed to provide a solution.


Hello @janambroz I get the same issue simply running a hello world app. How did you resolve this issue?
I get the same when running my Forge Cloud app.

Hi @Darin,

Unfortunately, I was not able to resolve this issue. I see this error in console, but looks like it does not affect the app.

If you find a solution, please let me know.

Thank you

Hi @janambroz I thought this ‘Failed to run init function’ error was the cause for an app I was writing to not load, however, I got past whatever issue I had, my app runs now, but I still get that error. So for me, my app loads and runs, but the error still occurs. So it might be that this is a red herring, and isn’t really the cause of your issue?

I also see the same error (removeOldAnalytics is not a function) with a Forge app that I’ve created. It doesn’t affect my app to any apparent extent; however, it’d be awesome to eliminate the error somehow.

I am also suffering from this same problem. It’s not slowing me down but would be nice to get a solution.