Expired license Error after upgrade/downgrade

Our Jira version was accidentally upgraded to a newer version, even though our license had already expired last year.

Upon starting Jira after the installation, we were given an error, that our license key was not supported for this version of Jira.
Therefore, I reverted the files and the database to the previously installed version (7.1.7). But strangely, I still get the same error, telling me

“JIRA support and updates for this instance ended on 10/Jun/16. JIRA updates created after 10/Jun/16 are not valid for the current set of licenses.”

But Jira 7.1.7 was released on 18-May-2016 (before June 10).

I’ve also tried reverting to 7.1.6 - but that doesn’t work either, because the database version (of our backups) is for 7.1.7

Now, we can’t access our Jira anymore, because our license is apparently expired for a version that we were running for the past year.

You’re best off reaching out to support.atlassian.com and see i they can help you out.

Thank you for your suggestion.
Upon trying to create a request, I was told that I’m not entitled to technical support, since our license has already expired - but the website allowed me to create a request regardless. I hope the atlassian support team will reply soon/at all.