Field 'Epic Link' does not exist or you do not have permission to view it


Some Jira instances return the error when we search for Epic Link with JQL:

'Epic Link' is not empty


{"errorMessages":["Field 'Epic Link' does not exist or you do not have permission to view it."],"warningMessages":[]}

The same error is returned for the search API and Jira expressions.

Does anyone know what may be the reason for the error? Is it possible to not have Epic link in your cloud Jira instance?

Hello @daniel2

The Epic Link field was deprecated quite some time ago.

Google ‘jira epic link deprecated’ for more information.

Hi @sunnyape, the field was removed from the REST APIs but it is still present in the UI and JQL.

The use of ‘Epic Link’ is still allowed via JQL, but as has been described in the deprecation documentation, that is only so as to not break existing JQL queries that use it. The same applies to the UI… until the change-over is complete this year, as per this documentation and the new configuration starts being rolled out.

The change-over is being done over a period of time, so it would be reasonable to assume SOME Jira instances still have the old configuration and SOME Jira instances now have the new configuration.

  1. What happened when you stopped using Epic Link for those ‘some’ instances that are problematic? Did the problem go away?
  2. When you looked at the UI of those problematic Jira instances, do they have the new UI with Parent or the old UI with Epic Link?
  3. When you tried doing a JQL search via the UI of those problematic Jira instances, did they allow the old Epic Link field to be used?

I believe there was an incident reported yesterday about this, and Atlassian said they were reverting the change that caused it. Are you still seeing the problem today?

@david2 Yes it’s a problem that seems to be separate from the ‘Parent link’ outage from yesterday.

The documentation mentioned by @sunnyape says that Atlassian will start removing Epic links from the UI and partly from JQL in 2023 but the corresponding developer notice explicitly says that JQL changes are out of scope:

Will Epic Link or Parent Link be removed from JQL?

No. Also, we will add full company-managed project support to the parent JQL, and it will become the recommended way of searching for issue’s children in JQL. Read our Community announcement about it .

Note that all changes to JQL (including the full support for parent JQL) are out of the scope of this notice and will be released separately.

@sunnyape I’d love to have access to the instances to answer the questions 2-3 :slight_smile: JQL without epic link works fine.

I just had a quick look at a couple of Jira instances that I’m working on, and they’re all still using the old config with a UI with Epic Link showing, so it looks like the change-over hasn’t started in our region yet.

Are you not able to contact the sys admins for those few problem Jira instances and ask them how their instance is configured? It would a great way to know for sure. You could also run a query against the Get field configurations endpoints to find out what fields they have, what screens are using them and which projects are using those screens. You’d then know if the Epic Link field is active and on the appropriate screens for the projects you are running the JQL against.

Personally, I stopped using both Epic Link and Parent Link fields about 6 months ago, when the deprecation notice came out, so all my code now uses Parent field and I’ve not had any issues, plus I’m future-proofed when the change comes to my region.

Good luck with finding the answer, and please post it here when you work it out.


Hi all, I confirm that Epic Link is still supported in JQL. My assumption is that this problem is caused by incorrect custom fields setup in that customer’s instance.

I think the suggestion from the last message is the best you could do here. Thanks for your help on this one @sunnyape!



Hi @KonstantinK

Thanks for confirming that Epic links are still supported in JQL.

Are any changes going to be communicated to vendors in the future? We are currently using ‘Epic link’ to identify issues that are children of epics in company managed projects. We could potentially use ‘parent is not empty and hierarchyLevel=0’ but this also matches issues from Advanced Roadmaps hierarchy because hierarchyLevel is set to 0 for higher levels above the epics.

Can you confirm that ‘Epic link’ doesn’t currently check the parent fields in the JQL and thus produce more results than desired? (mentioned here but not communicated to the vendors previously Upcoming changes: 'epic-link' replaced with 'parent' | Jira Software Cloud | Atlassian Support)

@sunnyape I’ve checked the fields configuration and it turns out that’s it’s a problem with language

On that instance the correct JQL clause names for com.pyxis.greenhopper.jira:gh-epic-link are cf[10101], Lien d'épopée but not Epic Link.

Thanks for your help!

1 Like