Forge App can not be installed

Hey developer community members,

I have problems installing my own forge Apps from the Marketplace listing. The app worked fine for the development and production environments and could be installed using forge install. After sharing the app and create a Marketplace listing the app still can be installed using forge install but not through the “Get it now” button from the marketplace. When I click on the button I am able to choose a site and click on install which redirects me back to my site but nothing happens, the waiting icon gets shown and nothing happens. This happened with many of my forge apps and the Atlassian Marketplace Approvers were also not able to install or test the app because they have the same issue.

Any idea what’s causing this behavior?

Hi @YassinBENNACEUR ,

Can you share the link to the app on the marketplace so that I can try myself?

I don’t know for sure what’s happening but there are a few things that we can look into and I have a few questions for you:

  • Is the app returned when searching for it via the “Find new apps” menu?
  • Where exactly do you see the “choose a site” option? I’ve just tried to install another Forge app from the Marketplace and there is no site choice in the process. Update: I understand now that the installation flow starts form the Marketplace website itself and not from within the product.
  • Is there any issue shown in the UI when the installation occurs? Maybe you can record a video of the installation attempt and share it with us here.

Update: I’ve also found the ticket you raised with the Marketplace support team.

Thanks,
Caterina

Hello @YassinBENNACEUR
In case you want to share your app before listing them on the Marketplace, you can refer the below link for the App distribution.
https://developer.atlassian.com/platform/forge/distribute-your-apps/#start-sharing-your-app

Thanks,
Garvit

Hi Caterina,

thank you for your answer. Here are answer to your questions:

Link to the App: https://marketplace.atlassian.com/apps/1225393/my-issue-people-map-for-jira-cloud?hosting=cloud&tab=overview

The app is not returned when searching via “Find new apps”

I posted the video to this ticket: [FRGE-277] App Marketplace Listing can't be installed or tested by the AMKTHELP Team - Ecosystem Jira

Thank you for your answer, Garvit.

So once I send the app to the Marketplace, I can not install it using the marketplace or the distribution link, until the app is approved?

If this is a normal behavior, I will mark your answer and close this thread :wink:

Thank you for the support

Cheers
Yassin