Forge Custom UI kit app doesn't work with tunneling

I’ve been trying to make the app work with forge tunnel , but it’s simply returning an error
it’s saying local host refused to connect , but it works completely fine when it is deployed ,
I followed all the steps , forge create → forge install for forge dependencies → forge install for the react app → npm run build for the react app → forge install on to the instance .
I tried out a few other things like running the react app on port 3000 and adding
tunnel:
port:3000
to the manifest.yml , but even this is not working
Also tried it in different browsers chrome,firefox , brave etc. either they keep loading without showing any information or just return this error “local host refused to connect”

Hi @random1knd,

I can see that other developers had similar issues when the web server has compression enabled due to the way the accept-encoding header is handled.

Are you able to disable the compression? Otherwise, it might be an option to have the browser not set the accept-encoding header as described in the tracking ticket for this problem [FRGE-552] - Ecosystem Jira.

Hope this helps,
Caterina