Forge deploy fails with unknown error

Hey guys,

since this morning after I updated forge cli to version 1.3.3 I can’t deploy my app. It fails with an unknown error.

            "__typename": "AppDeploymentTransitionEvent",
            "stepName": "Release Lambda functions",
            "createdAt": "2021-05-25T07:41:19.542Z",
            "newStatus": "DONE"
            "__typename": "AppDeploymentTransitionEvent",
            "stepName": "Release CaaS manifest",
            "createdAt": "2021-05-25T07:41:19.543Z",
            "newStatus": "STARTED"
            "__typename": "AppDeploymentLogEvent",
            "stepName": "Release CaaS manifest",
            "createdAt": "2021-05-25T07:41:20.112Z",
            "message": "Deployment failed with unknown error",
            "level": "ERROR"
            "__typename": "AppDeploymentTransitionEvent",
            "stepName": "Release CaaS manifest",
            "createdAt": "2021-05-25T07:41:20.113Z",
            "newStatus": "FAILED"

I found an old post (How to debug failed Forge deploy?) and tried the fixes mentioned there, but none seem to work.
Since it was an internal error last time, I thought maybe it is one this time too?

Any help is greatly appreciated.

Thank you!

1 Like

Digging into this, I’m hitting an error trying to install forge/cli@1.3.3

And it looks like others might be having trouble after upgrading to 1.3.3 as well: Error: Cannot read property 'type' of undefined - forge/cli v1.3.3. Maybe related?

Just to confirm, you were able to successfully install 1.3.3 yourself first?

yes I was able to install it. Though on the first try i got an error, I then uninstalled forge/cli completely and installed it again. This time without errors

Can you please paste your full error log and app id? That information will help us trace the specific failed deployment much faster than trying to look it up from your user account.

1 Like

I’ve sent you the App ID and the full error log via DM.

I have not been available for the past few days. In general, App ID is safe data that you can post to this thread and you can sanitise deployment logs. I have asked somebody from the team to have a look into this further.

App ID is : ari:cloud:ecosystem::app/e6aacd53-fd29-4278-bbb8-fc334fbbaab3
And the error log. (I removed all Tokens and Signatures)
error_log.docx (49.5 KB)

Hi @FilippoMatraxia,

Could you DM me your app manifest file? And can you also check if the app gets updated despite the deployment failure error message? I’d like to verify whether the deployment logs are misreporting errors.

We believe this was being caused by an internal issue and have tried a patch. Can you try again and let us know if the deployment continues to fail?

Sorry for the late reply, I wasn’t in office the last two days.
Unfortunately it doesn’t seem to work. I even tried to update to @forge/cli 1.4.0 but no success.
I saw that some people had problems with the Google Maps API, which I’m also using, so I tried to remove it, but this doesn’t seem to fix the problem either.

Just dropping the link here to the google apis question @FilippoMatraxia since there has been an update from our devs today: Failed to integrate with googleapis - #3 by kchan

Thanks! I had the project working with the API (I used forge/api and not the npm package and that worked). A colleague of mine is still using it in one of his projects, and as far as I know and that seems to work.

As of now even without using the API I can’t deploy.

Hi @FilippoMatraxia, if your deploys are failing without the API, this is likely a different issue.

Could you please create a new CDAC post with the output of forge deploy --verbose when it fails?

This will help us to diagnose the issue.

You may also want to try disabling snapshots via the manifest file. See documentation for how to do this:

What do you mean by CDAC? :sweat_smile:

1 Like

Community.Developer.Atlassian.Com :slight_smile:


Opened a new post: Forge deploy unknown error