Forge Install List returns Out-of-date version even if I upgrade the app

yy@yydeMacBook-Pro cycle-time-calculator % forge install --upgrade -e staging
To upgrade your app to use the latest scopes, select it from the list.
Press Ctrl+C to cancel.

? Select the site to upgrade: hangzhouace.atlassian.net

Upgrading your app on the Atlassian site.

Your app will be upgraded with the following additional scopes:

  • manage:jira-configuration
  • storage:app

? Do you want to continue? Yes

:heavy_check_mark: Site is already at the latest version

Your app in the staging environment is at the latest in Jira on hangzhouace.atlassian.net.
yy@yydeMacBook-Pro cycle-time-calculator % forge install list

Showing all the current installations of your app:

Are you able to reproduce the problem with a brand new Forge app?

I tried a few ideas on how to recreate your problem without much success. Everything for me is saying Lastest.

I’ve also sent a private message for app specific info

Hi again

I’ve talked with the team. This is a known issue that is getting worked on.

There is a discrepancy between what Forge CLI is saying and what’s actually installed.
It should not have any affect on the app. The latest version is installed.

The CLI will display “up to date” once someone will re-consent to the app in your site.

Let me know if this doesn’t fix the issues.

1 Like

Hi, facing the same issue as well, kind of relieved as I thought I was going crazy