Forge tunnel stuck on === Building code

I have several Forge apps in the development environment.

These apps have been working well, without any issues until Friday.

To troubleshoot, I created a forge app UI kit app

  • Forge create
  • Selected Jira ui kit, Jira admin page
  • Forge deploy
  • Forge install
  • Forge tunnel

This app worked, then removed it and tried again, but this time with Forge UI 2 preview
followed the same sequence, but its stuck on building code.

However, existing Forge UI kit apps are also getting stuck on Building code.
my forge cli version is 6.20.2
node 6.20.9

1 Like

Hi @ShawnDanisa ,

I think you might have to raise a support request for this.


I have the same problem since yesterday. Created a support ticket.

I also noticed that deployed apps complain about localhost from time to time, when no tunnel is running. This may be related to forge tunnel failing mid-flight.

forge cli 6.20.2
node v18.18.1
macOS Sonoma 14.1.1

Hi @ShawnDanisa

This is happening due to Docker issues with Mac OS Sonoma. So, you can use either of the following workarounds to bypass Docker dependancy with "forge tunnel.

  1. Switch to the New native Node.js runtime (Preview)
  2. Or, use @forge/sandbox-tunnel as detailed on Quick tip: Tunneling without Docker (useful for Apple Silicon / M1)

Feel free to raise a support request if you need clarification on this.

With Regards


Hi Team,

You can also see our post here about the root cause




I hit this “wall” Yesterday and got quick help after raising an ECOHELP ticket, which gave the same solution as @jrichards is linking to.

The combination of MacOS Sonoma and Docker is the culprit and disabling the Rosetta setting in Docker Desktop gets the forge tunnel going again.