Getting error while using Jira rest java client

Hello, I am trying to use jira-rest-java-client-api in my Jira server plugin.
I am using following versions,
Jira - 7.13.0
jira-rest-client. Version - 5.2.0

In my pom I have added jira-rest-java-client-api and jira-rest-java-client-core dependency like,

        <dependency>
            <groupId>com.atlassian.jira</groupId>
            <artifactId>jira-rest-java-client-api</artifactId>
            <version>${jira-rest-client.version}</version>
            <scope>provided</scope>
        </dependency>

        <dependency>
            <groupId>com.atlassian.jira</groupId>
            <artifactId>jira-rest-java-client-core</artifactId>
            <version>${jira-rest-client.version}</version>
            <scope>provided</scope>
        </dependency>

I have added scope as provided so when I am building project using maven (atlas-mvn clean package) there is no error, but when I am trying to start the Jira server, my plugin is not added to Jira.
Getting following error

Unable to resolve 185.0: missing requirement [185.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.jira.rest.client.api)

Also, If I have not added the scope as provided then getting an error for banned dependencies while building using atlas-mvn clean package.

Any help would be appreciated, Thanks.