Granting permissions to a Forge app redirects me to 400 page

Hello :wave:,

I installed our Forge apps Link Management and Usage Statistics directly from Marketplace into my dev Confluence instance and after that, I am unable to grant permissions to ANY Forge app. Note that before I did that, I was a developer of both of these apps. For each of them, I had a dev version of the app bound to my account. I am the only one from the team, who is experiencing this problem. It is not related to my Confluence dev instance, I tried it in 3 different Confluences.

When I open the app in my Confluence, I am asked to grant permissions, when I click on it, I am redirected to this screen:

… Which looks good. But once I click on the accept button, I receive 400:

I tried to revoke all permissions I granted to Forge apps but it did not help.

Any ideas? Does anyone experienced the same problem?
Thanks a lot for any help.

1 Like

@marketa.jancova welcome to the Atlassian developer community.

There is an Atlassian-wide incident that seems to be affecting all OAuth 2 and Forge Apps. For now, please subscribe to the incident status: Atlassian Status - Users may get logged out of their Atlassian accounts

When that incident is resolved, please comment here to let us know, if you are still seeing the problem.

1 Like

@marketa.jancova thanks for the detailed summary. We are working on the issue, you can follow the updates here https://community.developer.atlassian.com/t/forge-broken-authentication-flow/47331/3

1 Like

Thanks @waldemarnt and @ibuchanan, I did not know about the incident.
Sure, once the incident is solved, I will try it and let you know! :slight_smile:

@marketa.jancova We have finished testing the fix across environments. It should be working for everyone now. Could you test and let us know?

The issue was not related to Forge but to specific Atlassian users with some criteria that we are still investigating (probably the number of sites that they have access to).

Thank you!

2 Likes

Hello @waldemarnt, I can confirm that it works now. I have installed both apps on 2 Confluences and looks good. :ok_hand:
I will let you know if it appears again.

Thanks a lot for fixing it! :slight_smile:

1 Like