Having to redeploy and install in dev for effects in forge tunnel

I recently deployed my app to production. Now when I make code changes locally and then forge tunnel the effects don’t seem to have taken place.

It’s only when I run forge deploy and forge install --upgrade. Then when I run forge tunnel I find the changes have happened.

Does anyone know why this has happened? How can I rectify this so that changes will take place after running just forge tunnel without needing to deploy and install?

@Johnh,

There are known limitations about tunneling. The one that fits your symptoms reads:

  • If you make changes to the manifest.yml file, you must deploy the app with the latest manifest. This is needed for the tunnel to pick up the changes.

But for simple code changes, that shouldn’t be the case. Maybe you can explain more about which code you changed? I assume this was for UI code; which UI framework are you using?

2 Likes

Thanks very much, these are for changes to the index.jsx file. Simply even changing the text on a button or

requires a deploy to implement the changes. I’m using the UI kit.

It’s also worth noting that after deploying to the dev environment, when I then tunnel and reload the page, none of the console.logs appear that should be.

These things have all happened since I deployed the app to production and is now under review from the Atlassian team.

Thanks for your time in assisting.

I’ve realised the cause of it.

I was logged into the dev site as a different user to the user I was logged in on the command line. As soon as I logged into the site as the correct user all of the above issues went away.

1 Like