How to create new option values for single-select customfield whn importing values from CSV


How to create new option values when you import single select jira custom field values. I have seen this happening, but right now cant reproduce it. Is it somehow related to the options api-s that changed recently or Im just missing something.
I have tried both External System Import (for admins) and also Bulk create (for users). Played around with single select options context also, but still I can only import already existing option values.


theres same problem already described here also, but still no answer -
It seems some can create new options and some cant. So Atlassian answer would be perfect to describe how it really should work…

Have you been able to reproduce it since you’ve posted? Curious to know if any errors pop up in the browser console.

1 Like

No I havent - have created few new sites also to try out every kinda weird scenarios.
But at least one customer of ours is returning with this issue in a month. So I dont know how its possible, but have seen many Jira issues having single select field with attached option id that should not even be possible.