How to upgrade AUI from 5.9.24 to 8.3.5?

My user want to upgrade the confluence server, SDK plugin and AUI. Also my team new for confluence. So we need your helps to upgrade the below version,.

Current versions:
Confluence server : 5.9.4
AUI: 5.9.24 to
SDK: 6

Upgrade Version:
Confluence server : 7.1.0
AUI: 8.3.5
SDK: atlassian-plugin-sdk-8.0.16

Kindly assist and give the step by step suggestion to upgrade the versions.

Note: User given 3 weeks to upgrade the version for Vulnerability issues.

Thank You.

Hey @natarajan.vijayan

you can use our upgrade guide at https://confluence.atlassian.com/doc/upgrading-confluence-4578.html
I would suggest to upgrade to the most recent version of Confluence which is 7.3.2 as on today.

What exactly do you need to do with SDK and AUI?

Thanks.

Already I have upgraded the Confluence server. We are facing many issues after import the customized plugin(app) into server. Because the plugin developed in older version (Atassian SDK 6, Confluence 5.9 & AUI 5.9). So i am asked How to upgrade the customized plugin to latest versions.