How upload my add-on

I have developed a plugin for Jira that is already finished, the problem is that I want to permanently upload it (ie without using Ngrok since the connection is only temporary). I saved the plugin on a web server iis but the one I try to upload the plugin to Jira gives me this error:
An SSL error occurred when we tried to contact the add-on host at https://wwww.dev-incentro.com/atlassian-connect.json. Please try again later or contact the add-on vendor. See also Troubleshooting SSL issues in the developer documentation.
I don´t know what happen.
Could you tell me the steps to follow to upload the plugin to Jira without the Ngrok?
If the problem has to do with the certificates how do I solve it?
Thank you very much

I have found out that Jira does not allow the use of self-signed certificates. Does anyone know how to get valid certificates?

Depending on your configuration, you might want to take a look at https://letsencrypt.org or you’ll have to purchase them from an SSL certificate provider.

2 Likes

Just to expand on Daniel’s worthy answer, you need to obtain an SSL certificate somehow - Let’s Encrypt will get you one for free - and then install that certificate in IIS. When the Jira instance installs your add-on, it does so over SSL, which involves an SSL handshake with your add-on’s server. If you have an SSL certificate from Let’s Encrypt, or from some commercial certificate authority, installed on your server, then the Jira instance will successfully complete the SSL handshake, and all will be well.

Hi David, in our environment we are using signed certificates but we get the same error. Could you have a look to this issue: DEVHELP-3472 ?

Thanks in advance.

I don’t know where to find DEVHELP-3472. Is that issue publicly accessible? If so, please provide a link to it.

Sorry David. This is the link: https://ecosystem.atlassian.net/servicedesk/customer/portal/14/DEVHELP-3472

DEVHELP issues are closed off to be between you (the reporter) and Atlassian so most folks on here won’t be able to see it.

Hi @RubnLegarda,

Thanks for taking the time to post this in our community! This is a great collaboration and we appreciate you posting this here so other developers seeking the same answer can refer to this :slight_smile:

For any developer interested in following this problem, currently encountering this issue, or want to chime in - from our conversation in https://ecosystem.atlassian.net/servicedesk/customer/portal/14/DEVHELP-3472, the error message from ssllabs is “This server’s certificate chain is incomplete. Grade capped to B”.

Some discussions about this:

Cheers,
Anne