Insert Macro: editor not shown when using curly bracket

If I am inserting my macro with the “Plus” sign and choosing it from the macro browser, the editor/configuration page for that macro opens up.

But when I am using the curly bracket and choose the same macro there, not editor pops up. I have to double click the placeholder to get to the editor.

Is there some config to specify this behaviour?

1 Like

I think for the editor to open automatically in this case you need a macro parameter that is marked as required in the atlassian-plugin.xml :slight_smile:

Hi Sven, thanks for replying. Do you mind telling me which parameter that might be? =)

Thanks in advance.

See here. To mark a parameter as required you need to add the required attribute to it:

<parameters>
    <parameter required="true" ... />
</parameters>

Perfect. This did the trick!

I was not sure if I need a <param name"required">… to achieve that.

Thank you!

1 Like