JIRA REST API access

Dear All,
we are trying to access to our jira website from an external application home-made., but we have some trouble to access.

We have tried this url into a browser
https://our-web-site.atlassian.net/rest/api/3/issue/PS-2927
and we receive the correct response: a page with all data of this issue

The point si that when we tried to access using postman (application to test the rest-api request) we receive avery time the message Code 404 and a response about that we have not permission or that the issue doens’t exist.

We have created a token and we use this into the OAuth1.0 and the token that Jira has generated, but doens’t work. We tried to modified some permission, but nothing change.

Have you some suggestions for us?

Thanks, have a nice day

Hi @LucaLombardi,

Since you’ve been able to get the issue details via the browser using your browser session as authorization, the 404 error you receive when using postman is really due to a permission problem.

Are you using a token generated from Atlassian account? Once you have your token, try the following curl command:

curl -i --user your-email:your-token https://your-tenant.atlassian.net/rest/api/3/issue/PS-2927

The -i option includes the HTTP response headers in the output, just in case it doesn’t work so you can see what’s going wrong.

Regards,
Dugald

1 Like

Thanks very much

Now it works

Have a nice day

1 Like