Jira SDK missing Boards, Backlog, Active Sprints, etc

Hi,

I am currently trying to develop a new Jira plugin using the latest Jira SDK.
I run the ‘helloworld’ project using atlas-run on localhost:2990.

However, couple of things are missing compared to the actual Jira instance running on our server.
For example, the ‘Boards’ menu is missing.
On the left handside, the Backlog, Active Sprints, Releases icons are all missing as well.

For this new plugin to work, I will need info on Active Sprints.

Please advise.

It sounds like you are missing the Jira Software application. See https://developer.atlassian.com/docs/advanced-topics/configure-amps-to-run-jira-core-with-additional-applications-installed for more information on how to configure your add-on to also include Jira Software.

I added this to my pom.xml file and restart Jira:

             <application>
                <applicationKey>jira-software</applicationKey>
                <version>${jira.software.application.version}</version>
            </application>
            <application>
                <applicationKey>jira-servicedesk</applicationKey>
                <version>${jira.servicedesk.application.version}</version>
            </application>

but still no luck. Is there anything else that needs to be configured?

Hi,

I installed Jira Software and is running here:

I have an instance of Jira Core running here (this is where the plugin lives, but unable to see Board/Sprints/etc…):

This instance of Jira Core (running the plugin) still complains about the Jira Software not bring installed:

I have even tried linking it (not sure if I needed to do this, but attempted anyways and still no luck):

Please advise.

Hi, @anon80787577.

I tried on my test plugin right now without adding

            <application>
                <applicationKey>jira-software</applicationKey>
                <version>${jira.software.application.version}</version>
            </application>
            <application>
                <applicationKey>jira-servicedesk</applicationKey>
                <version>${jira.servicedesk.application.version}</version>
            </application>

part in <plugin>. For me to be able to see the “Boards” menu, I clicked Install in

(I used JSD in the screenshot because I clicked the Install button on Jira Software.) Are you getting any errors when “Install” was clicked?

On a side note, creating application links is not necessary for this scenario.

Cheers,
Ian

Hi @iragudo ,

Thanks for the reply.
I agree.

On my end, I see “Download” (never install), any idea as to why? I have even tried Downloading and installing the software and re-launching atlas-run, but it’s stuck on Download.

java needed to see proxy settings:

https://confluence.atlassian.com/jirakb/how-to-configure-an-outbound-http-and-https-proxy-for-jira-applications-247857187.html

Add jira.software.application.version property to the property tag:

<jira.software.application.version>7.9.0</jira.software.application.version>

cf https://community.atlassian.com/t5/Agile-articles/How-to-use-Jira-Software-functionality-in-a-Jira-plugin/ba-p/779854