Macro's **Editor** URL not updated following the base_url change in the descriptor

We have recently switched the host from to We created a new version and made the change public. On one of our own main instance the macro is not load the editor from the correct location.

Here is the latest descriptor: In the view mode, it is loading resources from the new URL. When we open the editor, it is loading from the old place.

We have done the following tests:

  1. One all other instances, the new version works fine. However, because we did not have the old version installed other those instances, we are not sure if that makes any difference.
  2. We tried to uninstall the macro. After we have uninstalled the App, the macro is STILL working (both view and editor are using the old version).
  3. We tried to load it from our server directly (not installed from the marketplace). The behaviour is the same: correct URL for view, old URL for editor.
  4. We tried to load it from the installation URL on the private listing page. The behaviour is the same.

I have run out of ideas now. I wonder if anyone had similar experience before. Please help.

This sounds a caching issue to me. But I am not sure if there is a way to invalidate the cache and force the instance to reload the descriptor (for the editor).