My own application does not load

I have been learning to write Jira applications (with some success, I might add). Last week I was able to load the example apps, for example jira-activity, but now it does not load anymore. I can see the app in the menu. When I start it, all I get is after some time:

Something’s gone wrong

Our team has been notified. If the problem persists, please contact Atlassian Support…

I have recreated the api-token, did not help. I can see, that there were some partial outages in APIs and Developer-services. Any ideas?

Some new info. In the browser console there is an error message: VM182:1 GET net::ERR_ABORTED 404

Hi @arir,

Welcome to the community and good job in writing Jira applications. That’s great to hear.

We are investigating a few similar issues and are wondering if this could be related to ngrok now enforcing an authtoken to serve HTML content.

Would you be able to check if there problem is resolved after installing an authoken for ngrok?
You will need to sign up to ngrok and retrive the token from the ngrok dashboard following the documentation available here: ngrok – documentation

You could also check if there is an ngrok.yml file on the computer in use, by default this would be saved in the /Users/<user>/.ngrok2/ngrok.yml on a Mac.

Once the token has been set, you’ll need to restart the ngrok agent by running npm start in the app folder.

If this is the problem, you should see a response like the following in the corresponding request for the https://<tunnel> request:

Let us know,


Great success! ngrok authtoken did the trick and I can continue my development. Thanks a lot!

@arir found my post and supplied a link here. This solution worked for me as well and I just wanted to say thank you @ccurti for resolving my issue!

Happy to help :slight_smile:

And thank you @arir for sharing the link in the other thread and to you as well @LorenzoPhillips for helping with your answers and comments with the other devs.

I’m developing Atlassian Connect app with a post function and authtoken did the trick but the HTML content still won’t load.
Every time I get this.
Screenshot 2022-01-04 at 15.52.57

If I turn off JWT auth and call the endpoint I get HTML. Also, I can see in ngrok activity that the endpoint is called when I view my post function. Any ideas?

Sounds like you haven’t included the Javascript client library

You’ll need this on all of your HTML pages as it handles the cross-domain bridge between your app and the product.

That’s not it. I have basically the same thing that’s in here Bitbucket. And the library is there.

I found this in the console: Refused to display ‘’ in a frame because it set ‘X-Frame-Options’ to ‘deny’.

In the meantime, some security configuration was added to our app and that’s why it stopped working.
I added http.headers().frameOptions().disable() as suggested here java - How to disable 'X-Frame-Options' response header in Spring Security? - Stack Overflow. It works now.