New issue view seems to be incompatible with third-party apps or does not support it

atlassian-connect-dev
atlassian-connect
new-issue-view
jira-cloud

#1

Hi All!
Atlassian has released a new issue view. Looks like it does not support display of elements of third-party apps on Jira Core or updates are rolled out quite slowly on clients hosts.
Has anyone problems with this? Any piece of advice will be appreciated.
The elements that are impacted are issue tabs and glance.
Thanks.

Sincerely, Vadim


#2

Well it depends on what you define as a problem. :slight_smile:

Can you expand on what you’re having trouble with?

The developer docs are available at https://developer.atlassian.com/cloud/jira/platform/new-issue-view-ui-locations/


#3

May also be of interest to the folks reading this: https://jira.atlassian.com/browse/JRACLOUD-69997 (JS API call to open the new dialog)


#4

We have a Jira Cloud app with a regular issue tab panel which is backwards compatible with a new issue view activity. This issue tab is accessible from a new issue view of all software projects, but not from Jira Core new issue view (however we are able to use this tab from standard view of Jira Core issues). Could anybody confirm Jira issue tab (or any other Jira AC module) is displaying in a new issue view of Jira Core (Business) projects?

Thanks,
Dmitry


New Jira Issue View
#5

Hi.

Our page uses AP.getTimeZone() method.

Documentation says:

Retrieve the current user’s timezone. If there is no logged in user, the server timezone is returned.

New Issue View gets following error:

Uncaught TypeError: Cannot read property 'timeZone' of undefined
    at Object.getTimeZone (batch.js:35394)
    at a._handleRequest (batch.js:35188)
    at a.b._receiveMessage (batch.js:35201)

at this code:

getTimeZone:function(a){a(a._context.extension.options.user.timeZone)}

#6

Hi!

One more problem with new issue view.
Issue web panel: http://take.ms/BvSqM
In bigger window it looks by following way: http://take.ms/aVa41


#7

One more problem with new issue view.
Issue web panel: http://take.ms/BvSqM
In bigger window it looks by following way: http://take.ms/aVa411

I have reported a similar problem to Atlassian Dev support just a few days ago. In my case, the panel looks good but I cannot scroll down if the content does not fit. I saw a few add-ons affected by this issue.


#8

Hi Everyone!

For the scroll issue of the new issue view, please vote, watch, or comment in JRACLOUD-70051

Cheers,
Anne Calantog


#10

Hi @Maarten,

Thanks for picking that up! I’ve corrected my post.

Cheers,
Anne Calantog


#11

Thanks, deleted my post to avoid confusion. Good to see that the scroll issue is known, we ran into this as well.


#12

@acalantog, Thank you for creating a Jira issue.

Nevertheless, the “Low” priority with such a small number of votes suggests that we won’t get the solution soon.
I’m not aware of any workaround available so it should be more important IMO.

UPDATE: JRACLOUD-70051 is now of Hight priority. Thank you, @acalantog

Cheers,
Jack


#13

Hi!

We added some workaround for AP.getTimeZone() problem. Now switching from Comments to any of our tabs works!

But switching from one our tab to another our tab does not work.

  1. No JS errors.
  2. Jira shows DefaultLoggerAPI.js:23 Add-on iframe timed out for add-on com.xiplink.jira.git.jira_git_plugin in console.
  3. Browser loads our IFrame and all our files: HTML, JS, CSS including atlassian-connect/all.js.
  4. Jira shows our IFrame with opacity: 0; height: 0px, Jira definitely wants to keep it hidden.
  5. Jira is not connected to our servlet: Our code calls AP.getLocation(callback), but callback never runs.

#14

I can also confirm, that when new Issue View is opened in Business project addon panels are not displayed. It does not matter if new modules or old ones are in atlassian-connect.json. Is this happening only on developer instances or is it live in such way?


#15

I can also confirm, that when new Issue View is opened in Business project addon panels are not displayed. It does not matter if new modules or old ones are in atlassian-connect.json. Is this happening only on developer instances or is it live in such way?

Same here. We have production customers complaining about this.

There are not answered questions from other vendors too:

@atlassian-staff, is there an open issue that we can vote?

Thanks,
Jack


Add-on not being displayed in business type projects
#16

Perhaps @tpechacek can shed some light on this?


#17

@maciej.dudziak @jack @Maarten We have updated Business projects to support add-ons on the new issue view. Everything should be working as expected for both the Board issue detail view (modal) and the Full Page issue view.

Let me know if you are having any problems.


#18

Great, thank you. It is working now :slight_smile:


#19

We’re seeing context variables fail to be added to the IFRAME URL on views like this: https://myserver.jira.com/projects/BIZ/board?issue-key=BIZ-1

That means we see things like this:
/ui/page.html?issue.key=&project.key=&user_id=admin&....

We expect issue.key and project.key to be present because that’s what we put in the Atlassian connect json.


#20

We’ve got some more problems… are these already being tracked?

  1. What’s mentioned here about weird panel display.
  2. We’ve got another case where if you use that drop-down to switch between what used to be tabs from comments, activity, our tabs that what happens is it works only if you come from comments tabs. Otherwise Jira generates a hidden IFrame but the Atlassian JS API does not work there – calling API methods do not respond to callbacks.

#21

@maciej.dudziak, @jack, @Maarten

@adam has opened DEVHELP tickets for the issues we see still remain:
Gray field on new issue view
Context variables are not properly expanded in new Jira Cloud issue view
Drop-down to switch between tabs fails