Hard to tell without even more information about your plugin. But it looks like this error has occurred in other cases. This can apparently happen when the plugin cache is corrupted: Unable to start the plugin container for plugin error during Jira startup | Jira and Jira Service Management | Atlassian Support. That’s a thing to start with. Otherwise, check out whether you have made all necessary upgrades related to Platform 7. This thread contains a lot of info there: Preparing for Confluence 9.0 - EAP out now