Official release: Jira 8.16 and Jira Service Management 4.16

Just a quick post to alert you all of the new JiraData Center and Server releases.

Jira Core 8.16 Server

Jira Software 8.16 Data Center and Server

Jira Service Management 4.16 Data Center and Server


Will there be official docker images as well?
Currently they do not seem to be available.

thanks :slight_smile:


I passed this to the team that fixed it for EAPs, I’ll post again when I get more details.


Hey, the images are available now.


Hi @tbartyzel,
thank you for the heads up!
With the release of 8.16 we are also experiencing another strange behavior regarding custom fields in addition to the previous fixed one mentioned in this blog post:
In our custom fields we are extending from EditCustomFieldOptions. We have implemented the setter setCustomFieldId(Long customFieldId) which used to work in prior versions (the method was invoked via reflections by the JiraSafeActionParameterSetter). But since Jira 8.16 it seems as if customFieldId is no longer available in this context and therefore the setter won’t be invoked anymore.
Could you maybe check, whether this is on purpose or if this is actually a bug at this point?

Thank you!
Cheers :slight_smile:

Hi, @JonaIttermannDecadis,

First of all, I think you can achieve the same result by calling getCustomField().getId() instead of creating the setter.

I’ve been trying to do what you’ve done in pre-8.16 Jira (8.13 in my case) and setCustomFieldId still isn’t called. The only time this method can be called from JiraSafeActionParamteterSetter is when there’s a “customFieldId” HTTP parameter (either from URL or request payload). There’s no such parameter passed to EditCustomFieldOptions, unless you have a custom HTML template which - obviously - I don’t have access to.

Hi @apawelczyk,
thanks for the reply! Yeah we also had this in mind and just wondered why it wasn’t working anymore. But grabbing the id via getCustomField().getId() is also just fine :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.