Power-up bugs (problems with modal and popup)

Demonstrations

https://youtu.be/UzGW2-E9_zA (popup)
https://youtu.be/wU1gAIlwEz4 (modal)


Actions (1)

  • Open any card.
  • Open modal from card-back-section (power up).
  • Click on the modal close icon

Expected: Modal is closed.
Actual: Modal and Card are closed.


Actions (2):

  • Open any card.
  • Open modal from card-back-section (power up).
  • Click under the modal (on card area)

Expected: Modal is closed. Card is opened.
Actual: Modal is opened. Card is closed.


Actions (3):

  • Open any card.
  • Open modal from card-back-section (power up).
  • Press ESC

Expected: Modal is closed. Card is opened.

Actual: nothing happens


Actions (4)

  • Open any card.
  • Open iframe popup from card-back-section (power up) with mouseEvent in params.
  • Click outside of popup

Expected: Popup is closed.

Actual: nothing happens


Actions (5)

  • Open any card.
  • Open iframe popup from card-back-section (power up) with mouseEvent in params.
  • Press ESC

Expected: Popup is closed.

Actual: nothing happens

Note: if you click in the popup window (set focus) and press ESC, the popup will be closed.
Note: if you open the date popup, ESC pressing will close the popup regardless of focus


Browser: Google Chrome (Version 79.0.3945.79 (Official Build) (64-bit)) on macOS 10.15.2 (19C57)

Thanks for the very detailed report of these bugs!

This is something our team is aware of and has queued to fix. Once we get the fix live, I’ll let you know. I don’t have an estimated date yet as a lot of folks are out for the holidays. As soon as I have more info, I’ll pass it along.

We are experiencing similar problems with our Power-Up, unfortunately it’s a breaking error this time:

Actions

  • Open search popup from card-back-section with mouseEvent in params

Expected: Card stays open, popup appears

Actual: Card disapears, popup appears, but selections are ignored


Observed under Windows 10 with Firefox, Chrome, and Opera.

How to replicate:

  • Install Power-Up 5d528954fa9d351cc088ab2c
  • Open a card and hit “Attach Process” (Power-Up button), choose “Empty Process”
  • In “Process” card back section hit “Add Existing Task” button

@bcook, can you confirm whether this bug is related and taken care of?

Thanks!

We have a version of Trello that we believe addresses these issues.

You can give it a try here: https://trello.com/support/try?name=cfletcher-classic-nested-popovers-layer-fix&version=3&time=999 This will set your session to use the updated version, so keep in mind that if you close the window, you’ll lose this version.

1 Like

Thanks for the link, @bcook!

As far as our bug (card is closed if popup is opened) is concerned, I can confirm that the problem has been solved in the recent production version (as well as in the build provided via the link).

1 Like