Problem with permissions after listing app in marketplace

I’ve asked permission for both Jira and confluence product API in my forge app. My app will install in Jira and it read and creates confluence pages from Jira.

Screenshot 2021-10-01 at 10.28.46 PM

It worked perfectly in development when I installed it on both Jira and confluence.

Group 74

After I listed my app in the marketplace, I installed my app in Jira and tried to run it. But now my app asks permission for only Jira and so my app is not working as it needs to call confluence product API.

I’m not sure why the permission for confluence is omitted and I’ve changed my app name to something else long back in development. But it still shows the same old name on the permission page.

Hi @santhoshvs,

The Atlassian Marketplace doesn’t currently support cross-product apps, the current suggested workaround detailed in that page is to create a separate listing for each product.

Hi @SamSmyth,
I’m just using confluence API to create a confluence page. I’m not using any modules related to confluence. Should I have to create a separate listing for this use case?

Sadly these cross-product API calls are not possible with Forge on Marketplace, I can’t find a relevant ask for this on our Forge feedback board, if you are interested in this feature would be great to leave a request there as the level of interest on features like this helps us roadmap them.

Sure @SamSmyth. thanks