Problems uploading app to cloud atlassian

Hi,
I’ve started today to study the documentation to upload an app at cloud atlassian.
Currently, I’m doing the Hello World app of the getting started documentation ( https://developer.atlassian.com/cloud/jira/platform/getting-started/ ).
But at step 3, where you have to upload the app, I’m getting an error.
I’ve seen on the server that Atlassian is trying to GET atlassian-connect-json and not atlassian-connect.json:
I’ve searched and it’s not a known issue, maybe I am doing something wrong? (yes, I’ve correct typed the url jejeje)

Thanks,
regards.

Welcome to the developer community, @agarcia!

What error are you getting? The URL you used for uploading the app, kindly try it in the browser to check if you can access the descriptor file publicly.

Cheers,
Ian

Hi @iragudo,
I’ve tried the URL in the browser, and I can access the descriptor file without problems.
I am not getting an error exactly (well, a 404), but Atlassian is trying to get atlassian-coonect-json, and not atlassian-connect.json.
I’ve tried to rename it to atlassian-connect-json, but even like this it doesn’t works…

Regards,

By any chance, can you share your descriptor URL here so that I can try it on my instance?

Thanks,
Ian

Are you using Express? Do you have the right route for atlassian-connect.json?
This works on that scenario.

app.get(’/’, function (req, res) {
res.format({
// If the req content-type is text-html, it will decide which to serve up
‘text/html’: function () {
res.redirect(’/atlassian-connect.json’);
},
// This logic is here to make sure that the atlassian-connect.json is always
// served up when requested by the host
‘application/json’: function () {
res.redirect(’/atlassian-connect.json’);
}
});
});