PUT to /rest/api/3/issue/<issueId>/assignee doesn't work correctly with accountId

I can assign a user to an issue with

curl -X PUT \
  https://<site>.atlassian.net/rest/api/3/issue/<issue id>/assignee \
  -H 'Accept: application/json' \
  -H 'Authorization: Basic xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' \
  -H 'Content-Type: application/json' \
  -H 'cache-control: no-cache' \
  -d '{
	"name": "customer1"
}'

Works fine. When I send

-d '{
	"accountId": "5b87a2axxxxx052b5f6590d5"
}'

as data it gets also a 204 response code back, but the assignee field in the issue is empty (not assigned). Even if it was assigned before.

Is the API here incomplete?

I think the “accountId” field only works if you opt-in to the GDPR changes. To opt-in, you’d need to use the “x-atlassian-force-account-id=true” header to test it. When I test the endpoint you’ve mentioned with the header, i.e. /rest/api/3/issue/{key}/assignee, I observe the same: by using the field “accountId” I receive a 204 response, but the assignee is not set when I view the issue.

And, as I already mentioned to you on Slack, there is a bug with the /rest/api/3/issue endpoint where you can’t use “accountId” for setting the assignee or reporter: https://ecosystem.atlassian.net/browse/ACJIRA-1613 It’s probably related.

There is no difference with the “x-atlassian-force-account-id=true” header. :frowning: I filed a bug.

There is no difference with the “x-atlassian-force-account-id=true” header. :frowning: I filed a bug - Is this bug resolved now? still its not working for me.

API responses related to user information have also been modified (for api v2). This: speak_no_evil: sad